1 min read

Problem with Ruby

Since some time now, I can’t write blog entries. Not because I don’t want to, but rather because the blog software has some issues. I’m the host to a archlinux user group. For this I had to create a website.

While I like octopress, it turns out to be a wrapper around jekyll. So I was thinking: Why not using it directly? So I started to use jekyll. I set it up and everything seems great. But I made a huge mistake. I used the same rvm environment to host the ruby code for the user group, as my Blog is using. By installing some new jekyll plugins I updated the rvm envionment, with a lot of gems. Next thing I know is that there is some strange issue with the octorpess.

   WARN: Unresolved specs during Gem::Specification.reset:
      pygments.rb (~> 0.6.0)
   WARN: Clearing out unresolved specs.
   Please report a bug if this causes problems.
   Invalid command. Use --help for more information

I had the hope to resolve this issue, but it didn’t went well. I was not able to fix it. So I just decidedto ditch octoress for something new..